Datenübernahme (Von Datenbanken) Was sollte man beachten !!

Was gibt es zu beachten wenn man Daten umzieht ? Also z.B. Daten von einem Alt-System auf ein neues System ?

Man sollte selbst nur Daten übertragen wenn man ganz genau weiß was man tut. Und nicht auf gut Glück oder mit der Einstellung irgendwie Geld sparen zu wollen, also nachdem Motto ich mach das alles selbst.

Man sollte bei Datensätzen nur Leute dran lassen die wirklich Ahnung haben und auch zugelassen bzw. Zertifiziert sind.

Was kann passieren wenn Ihr sparen wollt ?

Vom vollen Datenverlust bis zum vermeintlichen Erfolg bei der Datenübertragung mit vermischten oder Defekten Datensätzen. Letzteres ist sehr tückisch, denn man sieht es vielleicht erst nach längerer Zeit.

Wenn Ihr also Datensätze habt lasst nur Leute dran die wirklich Ihr Handwerk verstehen, denn solltet Ihr das Selber machen und dabei etwas sparen kann es am Ende wesentlich teurer werden, wenn Ihr die Datensätze nachpflegen müsst oder ähnliches.

Praxisbeispiel:

Bei einer Kundendatenbank die von einem alten CRM auf ein anderes CRM umgezogen werden sollte, hat der Besitzer sich gedacht ich spare mir die Transfer kosten und lies einen Bekannten dran der das machen sollte. Am Anfang ging auch alles, das neue CRM war wieder erreichbar und auf den ersten Eindruck war alles gut.

Nach 3 Monaten rief der Besitzer an und brauchte Hilfe bei seinem CRM da Datensätze fehlten und einige Datensätze vermischt sind. Er hatte leider Pech nach einer Überprüfung konnte man nur ein einen Datensatz vom alten CRM übertragen, diesmal aber richtig. Die 3 Monate musste er selbst nachtragen, also jeden Tag 4 Stunden Nacharbeiten.

Man sieht also das Sparen nicht überall gut ist. Dann doch lieber jemanden heran ziehen der das schnell und ordentlich macht.

Videokarte läuft nicht auf Server Hardware

Wie Ihr vielleicht wisst habe ich ja eine Videokarte von LevelOne die FCS-8005 für BNC Kameras.

Ich habe ja in einem vorherigen Artikel bereits getestet ob die Karte unter Windows Server 2012 R2 läuft, da es ja Offiziell von LevelOne nicht freigegeben ist. Soweit lief ja alles und ich konnte Sie unter Server 2012 R2 installieren und einrichten.

Jetzt nachdem der Ziel Server aufgebaut ist, habe ich die Karte eingesetzt und siehe da … der Server geht nicht an. Das selbe Bild das ich bereits bei anderen Server-Boards diagnostiziert habe.

Auf Anfrage bei LevelOne (Der Support war wirklich 1A), hat ergeben das es bei der Karte Kompatibilitäts-Listen gibt. Leider war mein Mainboard darauf nicht verzeichnet.

Also musste ein Plan B her um das Ziel doch noch zu erreichen.

Die Lösung sah dann so aus das ich ein zweites System aufgesetzt habe und die Karte dort installiert und eingerichtet habe. Das zweite System hatte dann ein Windows 7 32 Bit und wurde von mir entsprechend so eingerichtet das der Rechner 24 Stunden zuverlässig arbeiten kann.

Im Endeffekt war diese Lösung auch sauberer, als die Karte auf dem Server laufen zu lassen.

Fazit: Wenn ein Server-Board PCI Schnittstellen hat, heißt es nicht das dort auch direkt alles läuft. Bei Server-Boards und PCI Karten gibt es Listen der Kompatibilität. Also Vorab prüfen ist angesagt.

Test Umgebung wieder erreichbar

Soo … Jetzt gehts endlich wieder weiter … Mein Test Umgebung ist wieder erreichbar und ich werde nun wieder einige Experimente durchführen und natürlich neue Artikel verfassen.

Rückblick:

Nach einem Netzteil Brand ist meine Umgebung leider ausgefallen und ich musste erstmal für Ersatz sorgen. Das Netzteil war ja etwas älter aber auch nicht wirklich von einer Marke. Ich werde in Zukunft ausschließlich nur noch Qualitäts Netzteile verwenden, verbauen und empfehlen.

Virtuelle Laufwerke erstellen (subst)

Eine sache die ich so gefunden habe und doch sehr gut finde ist das erstellen von Virtuellen Laufwerken, das „substen“ von Ordnern also Ordner per Buchstaben direkt einzubinden.

Das ganze ähnelt dem „mounten“ von Linux Systemen.

Wofür braucht Ihr das ?

Weil Ihr vielleicht ein Verzeichnis auslagern wollt oder ein Programm nicht per UNC Pfad freigeben wollt.

Jedenfalls um ein Ordner zu Substen braucht Ihr das „Ausführen“ Fenster (WINDOWS TASTE + R)

Dort gibt Ihr ein:

subst X: C:\ZIEL_ORDNER

Beachtet bitte der Ordner muss existieren, er wird nicht angelegt. X: ist bei mir ein Beispiel für den Laufwerksbuchstaben der genutzt werden soll.

Die Hilfe und möglichen Befehle von „subst“ erhaltet Ihr über „subst /?“

Im ganzen gibt es nur noch zu sagen das dieses einhängen nach dem nächsten Reboot wieder weg ist.

Dem gegenwirken könnt Ihr mit einer Batch Datei im Autostart, also einfach den Befehl in eine .bat legen und im Autostart speichern.

Bei fragen meldet euch einfach.

Netzteil abgefackelt

Gerade heute erst passiert, mein Server der auf Abruf bereit steht wollte ich nach langer Zeit mal wieder aktivieren und am Anfang lief alles ich konnte per Net-KVM den Server starten und warten bis der Server hochgefahren ist.

Jedenfalls lief Parallel der Fernseher und mit gutem Sound, und dazwischen gab es einen komischen Ton so ein zischen mit kleinem dumpfen knallen, man hätte wirklich denken können das es aus dem Film ist.

Jedenfalls wurde es nachdem zweiten mal wirklich komisch, also stand ich auf und ging in den Raum wo der Server stand und siehe da der Raum steht unter weißem Rauch und es roch nach verbrannter Elektronik. Ich habe darauf hin direkt gehandelt und den Rechner vom Strom gezogen und alles abgesteckt, den Server geöffnet und das Netzteil sofort auf den Balkon gelegt. Alles lüften lassen … am nächsten Tag wollte ich dann die Ursache finden und habe das Netzteil geöffnet und gesehen das es tropft (Ölig schmierig), Optisch konnte man erstmal nicht wirklich was sehen, das Netzteil war ein gebrauchtes da das System also der Server aus gebrauchten Ressourcen stammt und Leistungs-Technisch noch super ist.

Das Netzteil schien bei der Kontrolle wirklich wie ein billiges No-Name Netzteil.

Ich habe beschlossen den Server erstmal komplett vom Strom zu lassen bis ich ein neues Qualitäts Server Netzteil bezogen habe und zusätzlich werde ich einen Rauchmelder installieren und eine überlast Steckdose einsetzen.

Ich möchte euch in diesem Beitrag davor warnen billige Netzteile zu nutzen, bei mir ging es noch gut, aber spart nicht an den paar €. Ich dachte warum ein neues Netzteil der Server läuft ja nur auf Abruf und das ging absolut nicht auf.

Ich bin nur froh das es noch so gut gelaufen ist, es hätte auch schlimmer ausgehen können.

Nvidia und AMD unter Windows Server 2012 R2

Da ich aktuell mit dem zusammenstellen eines Terminalservers beschäftigt bin und dabei auch soweit ganz gute Fortschritte gemacht habe möchte ich hier meine Erfahrung in Hinsicht auf Grafikkarten und Windows Server 2012 R2 mitteilen.

Das Mainboard das ich für den Server genommen habe hat nur eine Matrox mit 16 MB Speicher onboard. Der Speicher ist Dediziert und nicht erweiterbar. Nachdem ich alle Treiber installiert habe muss man sagen merkt man den geringen RAM sehr schnell.

Jedenfalls dachte ich mir,  baust du eben eine Nvidia Geforce GT 610 ein, eine einfache Mainstream Grafikkarte, die Karte ist von Zotac und mit PCI Schnittstelle. Sollte für ein Terminalserver reichen. Gesagt getan, Server startet und Treiber lässt sich auch installieren… Alles schön und gut… Dann aber kommt das große übel der Burn In Test… Der ganze Server stürzt bei 2D Darstellungen einfach ab. Klar die Karte hat keine direkte Unterstützung für Windows Server 2012 R2 64 Bit, aber für Windows 8.1 64 Bit, beide Systeme basieren ja auf dem selben Kern und ich brauche ja nur die 2D Leistung der Karte. Jedenfalls habe ich den neuesten Treiber genommen und auch den von der CD Alles ohne Erfolg… Am Ende musste ich die Karte entfernen da es nichts gebracht hat. Rein zufällig hatte ich dann noch eine Radeon HD 6450 mit PCIe Schnittstelle … also habe ich diese eingebaut und siehe da … von Anfang an Flüssiger und die Treiber konnte ich auch Problemlos installieren, die neueste Version natürlich von der AMD Webseite. Auch der Burn In Test war erfolgreich, der bei der Geforce gescheitert ist.

Jedenfalls habe ich auf meinem Mini-Server eine AMD APU mit Radeon Grafikkarte und der läuft ja bereits auf Windows Server 2012 R2, deshalb habe ich das als Option gesehen und es hat funktioniert.

Ich konnte die Radeon nicht direkt einbauen da der CPU Lüfter vom Server (AMD Opteron mit Dodeca Core 12 x 2,3 GHz) so riesig war das er mit den beiden Lüftern die PCIe Schnittstelle überdeckt. Ich habe daraufhin den einen Lüfter demontiert und die Temperatur beobachtet und diese blieb weiter stabil bei 38 Grad. Als Lüfter habe ich übrigens keinen Boxed Lüfter genommen sondern den Noctua NH-U9DO A3.

Jedenfalls stellt sich vielleicht dem einen oder anderen wieso nicht direkt eine Workstation Grafikkarte … Weil … diese erst ab 150 € aufwärts wirklich gut ausgestattet sind und die Radeon mit 35 € für die einfache tägliche Arbeit auf einem Terminal-Server reichen sollte.

Ich denke der Grund warum Geforce auf Windows Server 2012 R2 nicht funktioniert und nur die Workstation Grafikkarten zulässt ist, damit der Absatz der NVS Grafikkarten zunimmt, der Treiber ist konsequenter geschrieben und wirklich nur auf die Systeme zugelassen. AMD unterstützt es Offiziell nicht aber, die Tatsache das ich selbst Radeon und AMD APU auf R2 nutze und bisher beim 24 Stunden Betrieb keinerlei Probleme hatte kann ich sagen, wer eine günstige Grafiklösung für einen Terminal-Server sucht sollte sich an AMD und Radeon wenden, da werdet Ihr fündig.

Ich kann es wärmstens empfehlen da ich mit dem Mini-Server ständig per RDP drauf verbinde und die 2D Leistung reicht vollkommen aus. Klar ist diese Kombination nicht gedacht wenn Ihr auf R2 zocken wollt 😉

Neue Kategorie: ITK (Informations- und Telekommunikationstechnologie)

Ab heute gibt es eine neue Kategorie, ITK (Informations- und Telekommunikationstechnologie).

Die Kategorie, bezieht sich auf die Ausbildung zum Fachinformatiker Systemintegration. Es soll allen die sich in der Ausbildung befinden und als Nachschlagewerk dienen.

Windows-Bereitstellungsdienste Treiber hinzufügen (GUI-Version) (Experiment 01 Teil 3)

In dem 3 Teil meines Artikels, zeige ich euch wie man Treiber dem WDS Server hinzufügt.

Dabei ist wichtig das Ihr in erster Linie den Netzwerk Treiber einspielen müsst, da der Server vielleicht gefunden wird aber nach dem Booten abbricht mit der Fehlermeldung das keine Netzwerk Treiber gefunden wurden.

Deshalb zeige im Beispiel das hinzufügen von Netzwerk Treibern. Die Treiber müssen als „.inf“ Datei vorliegen, „.exe* Dateien etc. funktionieren nicht. Die „.inf“ Dateien beinhalten wie Ihr vielleicht wisst alles was benötigt wird für die Installation.

Die Treiber werden nach dem hinzufügen, allen Abbildern bereitgestellt außer Ihr habt es entsprechend gefiltert. Und Ihr solltet die Treiber sorgfältig zusammenstellen und möglichst unnötige oder veraltete Treiber entfernen. Und ihr solltet natürlich die Treiber schön in Gruppen sortieren um nachher einen Überblick zu behalten.

So jetzt mal genug geredet nun legen wir los:

1. Den Assistent startet Ihr durch einen Klick mit der Rechten Maustaste auf „Treiber“ und dann auf „Treiber hinzufügen“:

wdsd7

2. Hier könnt Ihr entscheiden ob mehrere Treiber oder nur einzelne Treiber hinzugefügt werden sollen, ich füge nur einen Netzwerkkarten Treiber hinzu, also erste Option und „Durchsuchen“ klicken:

wdsd1

3. Nachdem Scannen seht Ihr alle gefundenen Treiber, mit Architektur etc. nachdem überprüfen auf „Weiter“ klicken:

wdsd2

4. Nochmals zur Bestätigung und einfach mit „Weiter“ fortfahren:

wdsd3

5. Nach einem kurzen Augenblick, wird der Treiber hinzugefügt und wieder „Weiter“ wenn der Vorgang abgeschlossen ist:

wdsd4

6. Hier empfehle ich nun eine Gruppe zu erstellen, damit Ihr den Überblick behaltet, sonst schmeißt der WDS alle Treiber in einen Ordner, was sehr schnell unübersichtlich wird:

wdsd5

7. Filter definiere ich jetzt keine, also Option nicht abhaken und „Fertig stellen“ klicken, der Treiber wird in dem Falle allen Systemen und Images bereitgestellt:

wdsd6

8. Nun solltet Ihr unter dem Menüpunkt den Gruppennamen und den Treiber sehen.

wdsd7

Soo … im nächsten Schritt gibt es dann das hinzufügen von Abbildern und die Bereitstellung für den PXE Startvorgang.